
Measuring indicators on the availability and geographical accessibility 
of maternal health services at district level 

Case Study: Ghana 

WorldPop, University of Southampton 

(Date of last revision: 11/10/2022) 

Background 

Targeted monitoring is crucial for reducing inequalities in the provision of maternal health care services. 
However, monitoring largely occurs at the national level, despite guidelines for assessing the sub-
national coverage of services. This is likely due to historical limitations in the availability and accessibility 
of spatial data at these sub-national scales. This tutorial demonstrates how to estimate indicators for 
measuring the availability and geographical accessibility of maternal health services at the district level, 
using open data and tools. 

To estimate the availability of services, we use the World Health Organisation (WHO) guidelines for 
monitoring emergency obstetric care - defined as the number of CEmONC health facilities per 500,000 
population (WHO et al. 2009). 

To estimate the geographical accessibility of services, we use proposed indicators by Ebner et al. (2019) 
for measuring physical access to emergency obstetric and newborn care - defined as the proportion of 
pregnant women able to access CEmONC health facilities within a given travel time (%) (ACC2). We 
implement this method in QGIS, using outputs from AccessMod 5, a WHO tool for measuring physical 
accessibility to health care (https://www.accessmod.org/). 

Note: It is important to note that in this tutorial we assume that hospitals provide the comprehensive 
care as set out in the guidelines for classification of a CEmONC facility. 

Software 

The following software is required to complete this tutorial: 

• QGIS version 3.10 - https://www.qgis.org/en/site 

• AccessMod5 - https://www.accessmod.org/ (if not using the example travel-time dataset) 

Note: This tutorial assumes a basic knowledge of GIS, for example, familiarity with raster and vector 
data, and calculating zonal statistics, as well as a background knowledge in the use of maternal health 
indicators. Please also note that different versions of QGIS may have slightly different menu layout 
options to those described. 

Data 

The sample data for this tutorial can be downloaded from 
https://data.worldpop.org/repo/docs/wigley2022countdown_t1/. Download this data and save in a new 
project folder. All data are in the WGS-84 geographic coordinate system. The data includes: 

https://www.accessmod.org/
https://www.qgis.org/en/site
https://www.accessmod.org/
https://data.worldpop.org/repo/docs/wigley2022countdown_t1/


Hospital locations: 

Hospital locations for Ghana, clipped to the extent of the country, using the GADM level-0 dataset. The 
original dataset is available to download from the Sub-Saharan Public Hospitals Geo-coded database 
(gha_hospitals.shp). 

Ouma, P., Okiro, E. A., & Snow, R. W. (2017). Sub-Saharan Public Hospitals Geo-coded database - 
Population Health Dataverse. 
https://dataverse.harvard.edu/dataset.xhtml?persistentId=doi:10.7910/DVN/JTL9VY 

Note: We use the hospital locations provided by the Sub-Saharan Public Hospitals Geo-coded database, 
as it is a free and open data source. Though you could substitute this data for a more comprehensive 
one, including a facilities CEmONC status, if available for your application. 

Administrative boundaries: 

National and sub-national administrative boundaries for Ghana (adm0/adm2), available to download 
from the database of Global Administrative areas (GADM) (gadm36_GHA_2.shp). 

GADM. (2022). GADM data. https://gadm.org/data.html 

Note: We use GADM administrative boundaries because they are provided as open data, though you 
could substitute these to another boundary data set that you would like to aggregate the estimates for. 

Travel-time: 

Travel-time to hospital locations, clipped to the extent for Ghana, again using the GADM level-0 dataset. 
The original dataset is available to download from the figshare repository. Travel-time is measured in 
minutes, based on combined motorised transport and walking (Alegana et al. 2018) 
(TT_GHA_Extract.tif). 

Alegana, V. A. (2018). National and subnational variation in pattern of febrile case management in sub-
Saharan Africa. 
https://figshare.com/articles/dataset/National_and_subnational_variation_in_pattern_of_febrile_case_
management_in_sub-Saharan_Africa/7160363 

Note: We use this dataset for the example, which relates specifically to the hospital dataset for sub-
Saharan Africa. However, you could re-create this using AccessMod5, to be able to customise the input 
travel-time to your specific needs (you would need to do this if using an alternative health facility 
dataset). 

Population estimates: 

Estimates of population per (1km x 1km) grid square for Ghana for 2015, available to download from the 
WorldPop website (gha_ppp_2015_1km_Aggregated.tiff). 

WorldPop. (2022). WorldPop :: Population Counts. 
https://hub.worldpop.org/geodata/summary?id=31430 

Note: We use this dataset as an example, but you can use other raster population data. We use the 2015 
population estimates to match the pregnancy estimates (see next). 

Pregnancies estimates: 

https://dataverse.harvard.edu/dataset.xhtml?persistentId=doi:10.7910/DVN/JTL9VY
https://gadm.org/data.html
https://figshare.com/articles/dataset/National_and_subnational_variation_in_pattern_of_febrile_case_management_in_sub-Saharan_Africa/7160363
https://figshare.com/articles/dataset/National_and_subnational_variation_in_pattern_of_febrile_case_management_in_sub-Saharan_Africa/7160363
https://hub.worldpop.org/geodata/summary?id=31430


Estimates of the number of pregnancies per (1km x 1km) grid square for Ghana for 2015, available to 
download from the WorldPop website (GHA_pregs_2015_Resample.tiff). 

WorldPop. (2022). WorldPop :: Pregnancies. https://hub.worldpop.org/geodata/summary?id=991 

Note: The pregnancy estimates are only available for 2015, so we also use the population estimates for 
2015 also, despite more recent estimates available. This data set has been resampled to align the pixels 
to the population dataset. 

Setting up the project 

With the data downloaded and saved in project folder we can now set-up the project in QGIS. 

1. Open QGIS and double click on New Empty Project (see below), to load up a new map document 
(note: that the project coordinate system is set to EPSG:4326 - WGS 84). This will open a new QGIS 
project. We can now save this document by selecting Project → Save As and saving the project in 
the project file. You will need to select the location and name of the project file. 

   

2. Now, we can add the sample data to the project from the project file. First, we will add the 
population data. From the Layer drop down menu select Add Layer → Add Raster Layer… This will 
open the Data Source Manager|Raster dialogue box. Navigate to the project folder and select the 
population raster (gha_ppp_2015_1km_Aggregated.tiff) (note: you will need to make sure you 
select the .tiff file extension to load the data correctly). 

https://hub.worldpop.org/geodata/summary?id=991


   

  Add the pregnancies raster and the travel-time raster using the same steps. 

3. We will now visually explore the data and check the data aligns. Right click on the population raster 
in the Layers panel and select Properties… to open up the Layer Properties dialogue box (make 
sure that only the population raster is selected), the Symbology tab should be selected (see below). 
From the Min/Max Value Settings , set the Cumulative count cut and check/select +2.0 and -98.0 
% and select OK. 

  The symbology now highlights the minimum and maximum value areas in the raster more clearly, 
and we can see a minimum value of 4.26511 and maximum value of 511.806 in the Layers panel. 



   

4. We will do the same for the pregnancies and travel-time raster and experiment with the Render 
type to show these in a different colour. For this we need to select Singleband Pseudocolor, 
choose a color ramp from the drop-down menu, and Apply to preview the adjusted layer 
symbology 

5. Now we need to add the hospital locations and administrative boundary data. From the Layer drop 
down menu select Add Layer → Add Vector Layer… From the Data Source Manager|Vector 
dialogue box, navigate to the project folder and select the hospital locations (gha_hospitals.shp), 
and administrative boundaries (gadm36_GHA_2.shp). Again, we can adjust the symbology by right-
clicking on the layer in the Layers pane and selecting properties. 

  Now all the data has been added we can begin the analysis. 

Availability analysis 

First, we will look at the availability of services according to the WHO guidelines for monitoring 
emergency obstetric care, defined as the number of hospitals per 500,000 population. 



This indicator is calculated by multiplying the number of hospitals within a defined administrative unit, 
by 500,000 (see below calculation, from pg 107 (Form 4) of the guidelines - Calculation of indicators for 
geographic area), and states a minimum acceptable level of ≥ 1 per 500,000 population. 

(Total no. of comprehensive EmOC facilities in area/Population of area) x 500,000 

= No. of comprehensive EmOC facilities per 500,000 population (Indicator 1b) 

1. To calculate this we need to know a) the total no. of hospitals/CEmONC facilities per geographic 
unit, and b) the total population per geographic unit. 

a) To find the total no. of hospitals/CEmONC facilities per geographical areas (or district), we 
can use the Count Points in Polygon tool: 

  Click on Vector → Analysis Tools → Count Points in Polygon… and select the 
administrative boundary layer in the Polygons drop down menu, and the hospital location 
layer in the Points drop down menu. Set the output location and file name 
(gha_hospitals_count.shp, for example) in the Count box and set the file type to .shp to 
save the output file as a new shapefile. Select Run. 

  Right click the layer in the Layers panel and select Open Attribute Table. The NUMPOINTS 
column will show the total number of hospitals/CEmONC facilities per administrative unit 
(see below). 

   

b) To find the population per geographical area (or district), we can use the Zonal statistics 
tool. 



  From the Processing drop down menu, select Toolbox, and search for Zonal statistics (see 
below). Double click to open the dialogue box. 

   

  Select the population raster in the Raster layer drop down menu, and select the layer that 
was created using the Count Points in Polygon tool (i.e. gha_hospitals_count.shp) in the 
Vector layer containing zones drop down menu. In the Statistics to calculate option select 
Sum (see below), then Run. 



   

  Close the dialogue box and open the attribute table for the input vector layer, where there 
will be a new column sum, displaying the total population per administrative unit in 
addition to the already calculated NUMPOINTS (see below). 



   

2. We can now calculate the availability of hospitals per district/adm2 unit using the Field Calculator. 
Using the above calculation ((Total no. of comprehensive EmOC facilities in area/Population of 
area) x 500,000). 

  In the Processing toolbox, search for Field calculator. In the open dialogue box, select the updated 
administrative boundary data set (i.e. gha_hospitals_count.shp), Create a new field (name: calc), 
and set the Output field Type to Float. Then under the Fields and Values drop down menu, type in 
the calculation using the “NUMPOINTS” and “_sum” fields (see below). Click OK to run the tool. 



   

  A temporary layer called will have been created, inspect this layer, and then Export → Save 
Features As… to save to a permanent file (e.g. gha_EmOC_availability.shp). Open the attribute 
table to view the results of the calculation (see below). The calc field shows the number of 
hospitals/CEmONC facilities per 500,000 population, and states a minimum acceptable level of ≥ 1 
per 500,000 population. 



   

3. Adjust the symbology to see the districts where the number of hospitals/CEmONC facilities is less 
than 1. Select the symbol type to Graduated , choose a Color ramp , and Classify into 2 Classes of 0 
to 1, and < 1 (see below). Use the Identify Features tool to see the calculated value. 

   



   

Accessibility analysis 

Now we will look at the accessibility of services using indicators proposed by Ebner et al. 2019 for 
measuring physical access to emergency obstetric and newborn care (defined as the proportion of 
pregnant women able to access CEmONC health facilities within a given travel time (%) (ACC2)) (Ebener 
et al. 2018). 

We will consider an 80% minimum coverage, as suggested by the Lancet commission on Global Surgery 
(Meara et al. 2015), to determine access to timely essential surgery. 

This indicator is calculated by dividing the number of pregnant women residing in a specific geographical 
area (who are able to access a CEmONC health facility within a given travel time (numerator)) by the 
total number of pregnant women residing in the same geographical area (denominator), with a 
maximum suggested travel-time of 2-h: 

number of pregnant women living within 0 – 120 mins of the nearest hospital / total number of 
pregnant women (per district) 

Note: Again, we assume hospitals provide CEmONC functions as outlined in the guidelines. 

1. For this, we need to know a) the number of pregnant women residing in a specific geographical 
area who are able to access a hospital within 2-h travel time, and b) the total number of pregnant 
women residing in the same geographical area. 



a) To find the number of pregnant women residing in a specific geographical area we need to 
first reclassify the travel-time raster into travel-time classes of ‘0 to 120’ minutes, and ‘120 
minutes or more’. 

  In the Processing toolbox search for Reclassify by Table, select the travel-time raster in the 
Raster layer drop down menu, and open the Reclassification table dialogue box. In this, by 
clicking on Add row twice, enter the ranges 0 - 120, with a value of 1, and 120 - 140, with a 
value of 0. Click OK, then Run the tool. 

  Note: In the output raster we can see very few areas that have a travel-time of more than 
120 minutes to the nearest hospital, suggesting good accessibility for most areas. Now 
Export and Save Features As… to save the layer to permanent file (tt_0_180.tiff) 

   

  Now multiply the reclassified travel raster with the pregnancies raster to find the numbers 
of pregnant women living within 0 to 120 minutes of the nearest hospital. 

  In the processing toolbox search for Raster Calculator and multiply the reclassified travel-
time raster with the pregnancies raster. Additionally, set the Reference layer to the 
pregnancies raster, to automatically define the extent, cell size and CRS of the output 
raster. Set the Output file location and name (i.e. GHA_pregs_2015_tt_0_120.tif ) to save 
the output as a permanent layer. 



   

  Then run the Zonal statistics tool to find the number of pregnant women residing in each 
district who are able to access a hospital within a 2-h travel time. 

  From the Processing drop down menu search for Zonal statistics and double click to open 
the dialogue box. Select the ‘pregnancies within 0 to 120 minutes’ raster 
(GHA_pregs_2015_tt_0_120.tiff) in the Raster layer drop down menu and select the 
administrative boundary data set in the Vector layer containing zones drop down menu. In 
the Statistics to calculate option select Sum, and set the Output column prefix to 
‘0_120_preg_’ then Run. 

b) Run the tool again to find the total number of pregnancies per district, selecting the 
pregnancies raster (GHA_pregs_2015_Resample.tiff) in the Raster layer drop down menu, 
and setting the Output column prefix to ‘total_preg_’. Now we have both number of 
pregnant women within 0 to 120 mins of the nearest hospital, and the total number of 
pregnant women calculated for each district. Now Export and Save Features As… to save 
the layer to permanent file (gadm_pregs.shp). 



   

2. We can now calculate the accessibility of hospitals per district/adm2 unit using the Field 
Calculator, using the above calculation (number of pregnant women living within 0 – 120 mins of 
the nearest hospital / total number of pregnant women (per district)). 

  In the Processing toolbox, search for Field calculator. In the open dialogue box and select the 
administrative boundary data set (gadm36_GHA_2.shp). Create a new field (name: calc) and set 
the Output field Type to Float. Then under the Fields and Values drop down menu, type in the 
calculation using the ‘0_120_preg’ and ‘total_preg’ fields (see below). Click OK to run the tool. Set 
the Output file location and name to save the output as a permanent layer. 



   

   



  If we sort the column with the resulting calculated values we can see all districts have over the 80% 
threshold of pregnant women living within 0 to 120 minutes of the nearest hospital, and again we 
can adjust the symbology to visualise these values geographically. 

Results 

Having completed the analysis we can now ask the following questions: 

• How do the availability and accessibility of maternal health services vary geographically across 
Ghana? 

• What do the results indicate to be the biggest barrier to the accessibility of maternal health 
services in Ghana – availability or accessibility? 

• How are these definitions of availability and accessibility limited? How could the analysis be refined 
to better characterise the availability and accessibility of maternal health care services across 
Ghana. 

Further analysis: Repeat the accessibility analysis using a maximum travel-time of 60 minutes to the 
nearest hospital, how does this affect the definition of accessibility? 

Contributions 

This tutorial has been prepared by A. S. Wigley, based on previous work carried out by Wigley at 
al. 2020. 
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License 

You are free to copy and redistribute this tutorial under the terms of a CC BY 4.0 license. 

Disclaimer 

WorldPop, University of Southampton, and their sponsors offer these data on a “where is, as is” basis; 
do not offer an express or implied warranty of any kind; do not guarantee the quality, applicability, 
accuracy, reliability or completeness of any data provided; and shall not be liable for incidental, 
consequential, or special damages arising out of the use of any data that they offer. If users encounter 
apparent errors or misstatements, they should contact WorldPop at release@worldpop.org. 

Suggested citation: 

Wigley A., Nilsen K., Tejedor-Garavito N. 2022. Measuring indicators on the availability and geographical 
accessibility of maternal health services at district level. WorldPop, University of Southampton. doi: 
10.5258/SOTON/WP00741 
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